스프링에서 테스트를 위해 Junit을 실행하려 하면 다음과 같은 에러가 뜬다.



이는 본인의 스프링 버전이 4.1.5로 비교적 최신 버전을 쓰고 있는데 이것이 Junit 4.7 버전을 지원하지 않기 때문인 것 같다.


처음에 프로젝트를 만들 때 Junit 버전이 디폴트로 4.7로 돼 있다.


pom.xml로 가서 Junit 버전만 높여주면 간단히 해결된다. 




이처럼 버전 차이에 따른 에러는 찾기가 매우 어려우므로 주의가 요구된다.


Posted by 타다키치

댓글을 달아 주세요